Bank errors
An overview of all Bank errors you might encounter on the client and server-side.
Overview
We use standard HTTP response codes for success and failure notifications. In general, 200 HTTP codes correspond to success, 40X codes are for developer or user-related failures, and 50X codes are for Okra-related issues. We’re always working to minimise API errors related to Okra integrations and to address connectivity issues across bank infrastructure.
Breakdown of an Okra error
Balance
Common cause
- The bank is unable to fetch or retrieve a users balance
Troubleshooting steps
- The user should try re-connect to the bank.
- Prompt the user to check their internet connection
balance: {
type: 'error',
error: true,
status: false,
code: 1003,
method: 'Product Fetch Error',
message: msg || 'Unable to fetch balance. Please try again.'
}
Transaction
Common cause
- The bank is unable to fetch or retrieve transactions
Troubleshooting steps
- The user should try re-connect to the bank.
- Prompt the user to check their internet connection
transactions: {
type: 'error',
error: true,
status: false,
code: 1002,
method: 'Product Fetch Error',
message: 'Unable to fetch transactions. Please try again.'
}
Funds
Common cause
- Insufficient wallet balance for the transaction
Troubleshooting steps
- The user should visit the wallet page to top up their wallet.
funds: {
type: 'error',
error: true,
status: false,
code: 1005,
method: 'Wallet Inssuficient Funds',
message:
'Uh oh! There was an issue, please contact ' +
name +
' for more information.'
}
Token
Common cause
- The user-provided an invalid token
Troubleshooting steps
- The user should provide an accurate valid bank token
token: {
type: 'error',
error: true,
status: false,
code: 1010,
method: 'Invalid Token',
message:
'You entered invalid token credentials, please check your token and try again!'
}
Validation
Common cause
- The user-provided an invalid token
- The details provided by the user is not recognized by the bank
Troubleshooting steps
- The user should provide an accurate valid bank token
- The user should check their login details
- The user should check their internet connection
validation: {
type: 'error',
error: true,
status: false,
http_code: 401,
code: 1000,
method: 'Validation',
message: msg ? `ERROR FROM ${(name && name.toUpperCase()) || 'BANK'}
\n${msg}` : 'Validation failed please confirm credentials and try again'
}
Answer
Common cause
- The user provided an invalid secret answer
Troubleshooting steps
- The user should provide an accurate and valid secret answer
- The user should reset their secret question from their financial institution
answer: {
type: 'error',
error: true,
status: false,
code: 1011,
method: 'Invalid Security Question',
message:
'You entered and invalid secret question aswer, please try again!'
}
Incomplete_Profile
Common cause
- The user has not completed their bank profile
- The financial institution does not recognize the profile
Troubleshooting steps
- The user should go to the bank branch and complete it
incomplete_profile: {
type: 'error',
error: true,
status: false,
code: 1033,
method: 'Incomplete Account Profile',
message: 'Whoops! It seems your ' + name + ' profile is not completed. Kindly goto bank branch and complete it.'
}
UnImplemented
Common cause
- The financial institution is not MFA enabled on Okra, check the list of bank coverage.
Troubleshooting steps
- The user should try and log in with their web credentials.
unimplemented: {
type: 'error',
error: true,
status: false,
code: 1001,
method: 'Unimplemented Bank ',
message: 'Uh oh!, It seems this bank have not been implemented yet please try and login with your web credentials bank.'
}
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